?>

Hard Copy World

HCW

Q&A

Home > Forum >

Q&A

안녕하세요. esp8266 sming 질문 드립니다.

페이지 정보

작성자 바가오리 쪽지보내기 메일보내기 자기소개 아이디로 검색 전체게시물 작성일16-05-06 15:00 조회930회 댓글3건

본문

정말 감사하게 게시글의 도움을 받고 있는 학생입니다.

저는 esp-12e 모듈을 사용하고 있습니다.

처음 사용하는것이라 낮설지만 차근차근 따라하고 있었는데

Basic_Test 를 하는 중이였습니다.

빌드에서는 에러가 안뜨는데 flash에서 에러가 떴습니다.

그림 같은 에러 인데 cmd에서 dir %ESP_HOME%

를 입력하면  스위치가 틀립니다 - "Espressif". 라고 뜹니다.

혹여나 이것떄문에 잘못되는 것인지 알맞게 고치려 했으나

잘 모르겠어 질문을 올립니다.

에러를 고치려 게시글에 있는 방법을 몇개 해보았습니다.

esptool2.exe  C:\Espressif\utils 에다 넣기

환경 변수 path 에 GNU 경로 넣기

환경 변수ESP_HOME C:/Espressif 를 C:\Espressif 로 바꾸기

Makefile-user.mk 복사해서 넣기

sdk 재 설치 하기

전압 확인하기

지속적인 flash 해보기

어떻게 해야 flash 가 될까요?

 

추가.

자세히 보니 build 후 *.bin 파일이 생성되어야 된다고 하셨는데

cmd로 확인해보니 bin 파일이 생성인 안되네요.

에러에도 out/firmware/0x00000.bin 파일을 찾을수 없다고 나오네요

추가2.

Espressif-ESP8266-DevKit-Addon 을 다운 받은후에

install-mingw-package.bat을 실행시키는데

관리자 권한을 줘도 자꾸 권한이 없다고 나오네요.

cmd 를 관리자 권한으로 켜서 cmd를 통하여 켜도 권한이 없다고 하고

자체 파일을 관리자 권한으로 바꿔도 안되네요..

댓글목록

최고관리자님의 댓글

최고관리자 쪽지보내기 메일보내기 홈페이지 자기소개 아이디로 검색 전체게시물 작성일

마지막 이미지의 에러를 보면 COM 포트를 잘못 지정했거나 인식이 안된 경우가 아닌가 싶습니다. FTDI 모듈이 제대로 잡히는지 COM 포트 넘버가 맞는지 확인을 하셔야 할 것 같습니다.

바가오리님의 댓글

바가오리 쪽지보내기 메일보내기 자기소개 아이디로 검색 전체게시물 댓글의 댓글 작성일

펌 업데이트가 되길래 되는 줄알았는데... 또다시 같은 문제가 생겨 문의 드립니다..ㅠ
GPIO0를 gnd로 줘서 업데이트 후 10k 저항을 통한 vcc로 변경 후
이클립스를 통하여 flash 하려는데 같은 오류가 발생합니다.
업데이트가 된건 접속이 된것 아닌지요?
제가 어떤 방법을 해야 될지 모르겠습니다..

최고관리자님의 댓글

최고관리자 쪽지보내기 메일보내기 홈페이지 자기소개 아이디로 검색 전체게시물 댓글의 댓글 작성일

혹시 다른 곳에서 해당 COM 포트를 사용하고 있진 않나요? 이런 유형의 문제가 자주 나오는데 COM 포트 인식 문제 아니면 Makefile 의 설정 문제가 주인것 같습니다. 그런데 저도 정확히 어디가 문제인지는 잘 모르겠습니다. 일단 COM 포트 인식에 문제가 없다면 (장치 관리자 확인) makefile에서 COM 포트 정확히 지정해주시고, 컴파일-업로드에 관련된 경로나 설정들을 다시 확인해봐야 할 것 같습니다.